Ca march’pas...

Le 15 septembre 2009, par Jeff,

Une aimable lectrice vient récemment d’attirer mon attention sur le fait qu’elle ne pouvait pas poster de commentaires sur ce site (ce qui est bien dommage, vu le long commentaire argumenté qu’elle a fini par laisser !), faute de voir l’image de la captcha en bas du formulaire de forum.

Et, après avoir un peu fouillé, j’ai du constater qu’elle avait raison.

Certaines fois, sans que je saches pourquoi, spip propose une adresse complètement farfelue pour les articles du site, du genre

http://jfmoyen.free.fr/IMG/plugins/blip/IMG/cache-gd2/plugins/spip.php ?article 123 (la bonne adresse est plus simple : c’est http://jfmoyen.free.fr/spip.php ?article123 , sans tout les bazars au milieu).

Je ne sais pas quel est la cause du bug ; mais il s’est manifesté dans les adresses diffusées par le flux rss (je crois que j’ai réussi à l’éradiquer à cet endroit, mais je ne suis pas certain !), et, apparement, sur la page d’accueil du site et dans les liens internes (là, je n’ai pas réussi à le flinguer). Le problème est que l’effet est assez subtil : vous pouvez voir la page à peu près complète, mais il manque quelques éléments comme l’image captcha des forums, peut être les animations du diaporama. Bref, c’est pas un gros bug qui saute aux yeux...

En attendant que j’arrive à régler le problème, on peut le contourner en vérifiant dans la barre d’adresse que vous êtes bien sur /spip.php ?articleXXX (et rien d’autre) ; le cas échéant en corrigeant l’adresse à la main...

On y travaille, mais...

Téléchargez cet article au format pdf : Enregistrer au format PDF
 

Commentaires de l'article

 
Rémi
Le 19 septembre 2009

Il m’est aussi arrivé une fois d’être envoyé sur une page en http://...spip.php/ecrire/ecrire/spip.php ?articleXXX.

Là aussi, toutes les images de la page (incluant le captcha, mais aussi l’icône PDF et autres) avaient disparu. Une fois l’adresse nettoyée (i.e. sans le /ecrire/ecrite/spip.php de trop), tout va bien.

 

Attention !

Suite à un bug que je n’arrive pas à résoudre, vous êtes peut-être arrivés sur cette page, ou d’ailleurs sur n’importe quelle page du site, avec une adresse (url) incorrecte. Si c’est le cas, il y a des choses qui marcheront mal (documents liés, commentaires...).

Les adresses correctes sont de la forme

http://jfmoyen.free.fr/spip.php ?articleXXX

Toute autre version (avec des choses en plus entre le "... free.fr/" et le "spip.php") n’est pas bonne.

Si vous n’arrivez pas à écrire un commentaire ou voir une photo, vérifiez que vous pointez bien sur la bonne adresse ; si vous faites un lien vers ce site, merci d’utiliser la version correcte de l’URL.

 

A propos de cet article

Dernière mise à jour le :
15 septembre 2009
Statistiques de l'article :
2236 visiteurs cumulés
 
 
SPIP 1.9.2g | BliP 2.2 | XHTML 1.0 | CSS 2.0 | RSS 2.0 | Espace privé
Visiteurs par jour (cumul) : 128 (744761)